Sommaire

Les boucles

Exercice 1

Quel algorithme permet d’afficher les nombres pairs entre 1 et 10 ? Fournissez le programme Python associé. Que faut-il simplement faire pour afficher ensuite les nombres impairs ?

Réponse

Programme Pair 
VAR 
    a:entier 
            
DEBUT 
    a←1 
    Tant Que a<=10 
      Si a MOD 2 = 0 Alors 
        Afficher a 
      FinSi 
      a←a+1 
    FinTantQue 
FIN

Ceci se traduit en Python comme ceci :

a=1 
while a <= 10: 
    if a%2==0: 
        print(a) 
    a=a+1

Ce qui donne :

> python correction_chap4_exo1.py 
2 
4 
6 
8 
10

Il suffit de modifier le test du Si pour sortir les nombres impairs :

if(a%2==1):
    print(a);

Le même algorithme avec une boucle Pour :

DEBUT 
    a←1 
    Pour a De 1 à 10 Faire 
      Si a MOD 2 = 0 Alors 
        Afficher a 
      FinSi 
    FinPour 
FIN

Exercice 2

Écrire un algorithme qui calcule la somme de tous les chiffres de 1 à n. Utilisez tout d’abord Tant Que, puis Pour. Fournissez les deux possibilités dans ...