Sommaire

La fonction SI FONCTION:SI

Une question, deux réponses possibles

Fonction incontournable qui rend bien des services. Elle permet de choisir la réponse à obtenir selon une condition.

Sa structure est la suivante :

=SI(question ; valeur si réponse positive ; valeur si réponse négative)

Elle pourrait se traduire par :

SI question vérifiée ALORS renvoyer valeur SINON renvoyer autre valeur.

Question : la question consiste à comparer le contenu d’une cellule à un élément en utilisant les signes égal =, supérieur >, inférieur <, supérieur ou égal >=, inférieur ou égal <=, différent <>. Cette question est de type logique, c’est-à-dire entraînant la réponse oui ou non (vrai ou faux).

Cet élément peut être une valeur numérique (A1>1000), une valeur texte à écrire entre guillemets (A1="bonjour"), une référence de cellule (A1=B1), une formule (A1>somme(B1:C1)).

Valeur si réponse positive : correspond à la valeur à renvoyer si la réponse à la question est positive (vrai). Cette valeur peut être numérique (100), texte ("bravo") ou le résultat d’un calcul (A1*10%).

Valeur si réponse négative : correspond à la valeur à renvoyer si la réponse à la question est négative (faux) ; elle peut être numérique, ...