Sommaire

Évaluation de formule OUTILS:Évaluation de formule FORMULE:Évaluer FONCTION:DROITE

Lorsque nous entreprenons des formules de calcul complexes, nous obtenons parfois des réponses inattendues. Nous avons beau lire et relire notre formule, l’erreur ne nous saute pas aux yeux. Il est intéressant alors d’utiliser l’outil Évaluation de formule.

Voyons son fonctionnement avec un cas simple :

images/02SOB16N.PNG

Le code produit est composé de deux parties séparées par un tiret : une référence et un prix.

Nous avons besoin de calculer en colonne C la valeur en stock pour les produits dont le prix est supérieur à 6. Pour ce faire, nous allons saisir en C2 la formule suivante :

=SI(DROITE(A2;5)>6;DROITE(A2;5)*B2;"")

La fonction DROITE renvoie le nombre de caractères spécifiés (5) d’une cellule (A2) en partant, comme son nom l’indique, de la droite. Ce qui donne 05,60, la virgule comptant pour un caractère.

Une fois votre formule validée, vous obtenez 67.2.

images/02SOB17N.PNG

Pourtant, 05.60 est inférieur à 6. La fonction ne devait rien nous renvoyer.

C’est là qu’entre en jeu l’outil Évaluation de formule.

Sélectionnez la cellule C2 qui contient la formule.

Onglet Formules - groupe Vérification des formules - bouton Évaluer la formule

images/02SOB18N.PNG

Cet outil va évaluer, au fur et à mesure, votre formule en soulignant à chaque fois l’élément sur lequel ...