Les boucles

Exercice 1

Quel algorithme permet d’afficher les nombres pairs entre 1 et 10 ? Fournissez le programme C# associé. Que faut-il simplement faire pour afficher ensuite les nombres impairs ?

Réponse


Programme Pair 
VAR 
    a:entier 
            
DEBUT 
    a←1 
    Tant Que a<=10 
      Si a MOD 2 = 0 Alors 
        Afficher a 
      FinSi 
      a←a+1 
    FinTantQue 
FIN
 

Ceci se traduit en C# comme ceci :


class chap4_pair 
{ 
    static void Main(string[] args) 
    { 
        int a = 1; 
 
        while (a <= 10) 
        { 
            if (a % 2 == 0)  
                System.Console.WriteLine(a); 
            a++; 
        } 
    } 
}
 

Ce qui donne :


> chap4_pair.exe 
2 
4 
6 
8 
10
 

Il suffit de modifier le test du Si pour sortir les nombres impairs :


if(a % 2 == 1) 
   System.Console.WriteLine(a);
 

Le même algorithme avec une boucle Pour :


DEBUT 
    a←1 
    Pour a De 1 à 10 Faire 
   ...
Pour consulter la suite, découvrez le livre suivant :
couv_RICSHALG.png
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Tests et logique booléenne
Suivant
Les tableaux et structures