Corrigé 14 Routage inter-VLAN

Entrez les commandes suivantes sur le routeur :


Router>enable 
Router#configure terminal 
Router(config)#interface FastEthernet0/0 
Router(config-if)#ip address 192.168.1.254 255.255.255.0 
Router(config-if)#no shutdown 
Router(config-if)#interface FastEthernet0/0.10 
Router(config-if)#encapsulation dot1Q 10 
Router(config-if)#ip address 192.168.10.254 255.255.255.0 
Router(config-if)#interface FastEthernet0/0.20 
Router(config-if)#encapsulation dot1Q 20 
Router(config-if)#ip address 192.168.20.254 255.255.255.0 
Router(config-if)#end 
Router#
 

L’interface FastEthernet 0/0 du routeur est configurée en « trunk ». Entrez les commandes suivantes sur le commutateur pour établir le trunk :


Switch>enable 
Switch#configure terminal 
Switch(config)#interface FastEthernet 0/1 
Switch(config-if)#switchport mode trunk 
Switch(config-if)#end 
Switch#
 

Sur certains modèles (gamme 2900XL par exemple), il sera nécessaire de configurer le protocole de trunk pour être en adéquation avec le protocole utilisé par le routeur (entrez la commande suivante sur l’interface trunk : switchport trunk encapsulation dot1q).

Pour configurer les VLAN, entrez les commandes suivantes :


Switch#configure terminal 
Switch(config)#vlan 10 
Switch(config-vlan)#name vlan10 
Switch(config-vlan)#exit 
Switch(config)#vlan 20 
Switch(config-vlan)#name vlan20 ...
Pour consulter la suite, découvrez le livre suivant :
couv_TP5CIS.png
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Corrigé 13 Sécurisation de port par sticky MAC
Suivant
Introduction