Tests et logique booléenne

Exercice 1

Écrire, avec des comparaisons, un algorithme qui affiche l’état de l’eau (glace, liquide, vapeur) en fonction de sa température.

Réponse


PROGRAMME ETAT 
VAR 
  T :numérique 
DEBUT 
  Afficher "Température ?" 
  Saisir T 
  Si T<=0 Alors 
    Afficher "C'est de la glace" 
  SinonSi T<100 Alors 
    Afficher "C'est liquide" 
  Sinon 
    Afficher "C'est de la vapeur" 
  FinSi
 

Exercice 2

Écrire le même algorithme, mais en utilisant deux variables booléennes pour vérifier l’état de l’eau, sans comparaisons dans les SI.

Réponse


PROGRAMME ETAT 
VAR 
  T :numérique 
  A,B :booléens 
DEBUT 
  Afficher "Température ?" 
  Saisir T 
  A←T<=0 
  B←T<100 
  Si A Alors 
    Afficher "C'est de la glace" 
  SinonSi B Alors 
    Afficher "C'est liquide" 
  Sinon 
    Afficher "C'est de la vapeur" 
  FinSi
 

Exercice 3

Écrire un algorithme qui détermine la catégorie sportive d’un utilisateur en fonction de son âge :

  • 6 à...

Pour consulter la suite, découvrez le livre suivant :
couv_RICSHALG.png
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Les variables et opérateurs
Suivant
Les boucles