Sommaire

Installation native de Metasploit Metasploit:installation

Malgré la complexité de l’outil, Rapid7 met à disposition des installeurs pour le Framework Metasploit. Ces installeurs sont actuellement disponibles sur les plateformes GNU/Linux, Mac OS X et Windows.

Ces derniers permettent une installation simple et rapide du Framework grâce à l’inclusion de l’ensemble des dépendances nécessaires (John the Ripper, Nmap, etc.).

Avant de procéder à l’étape d’installation, il est nécessaire de s’assurer que les plateformes répondent à différents prérequis. En effet, dans un souci d’une utilisation optimale, Rapid7 préconise les actions suivantes.

Vérifier le matériel

Afin de disposer d’un outil réactif, il est conseillé de disposer de la configuration suivante :

  • un processeur cadencé à 2 GHz+

  • 4 Go de mémoire RAM (8 Go recommandés)

  • 1 Go d’espace disque (50 Go recommandés)

Les recommandations concernant le matériel pouvant être amenées à évoluer, il est préférable de se référer à la documentation officielle sur le site de Rapid7 : https://www.rapid7.com/products/metasploit/system-requirements

Désactiver votre antivirus

En restant du bon côté de la barrière, Metasploit est un outil permettant de découvrir et d’exploiter ...