Installation de Ruby Tk

TK est une librairie de composants graphiques multiplates-formes. Chaque composant graphique s’appelle une widget (dans la documentation on trouvera également window). TK n’est pas inclus avec la distribution standard de Ruby et doit être installé indépendamment. La distribution standard intègre cependant tout le code pour travailler avec Tk. Tk est généralement associé au langage de script Tcl (Tool Command Language), donc si vous disposez de Tcl, il y a de forte chance que Ruby puisse fonctionner avec Tk.

1. Windows

Le plus simple pour disposer de Tk, est d’installer ActiveTCL. Il vous suffit d’aller à cette page : http://www.activestate.com/Products/activetcl/feature_list.mhtml puis de télécharger cet outil par le lien Get ActiveTcl. Attention à télécharger une version 8.4 et non 8.5. Au moment de la rédaction, la version 8.5 n’était pas compatible avec la version 1.8 de ruby. Attention également à redémarrer votre environnement de développement (par exemple NetBeans).

2. Linux

Vous devez installer Tcl/Tk et Ruby Tk (Ruby’s Tk bindings). Si vous êtes sur une distribution Ubuntu, vous devez installer le package libtcltk-ruby. Cela peut se faire par la commande : sudo apt-get install libtcltk-ruby.

Un RPM est également disponible ruby-tk-UneVersion.i586.rpm.

Dans tous les autres cas, il vous faut installer tcl/tk puis compiler Ruby en précisant...

Pour consulter la suite, découvrez le livre suivant :
couv_Ruby.PNG
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Exercices
Suivant
Programmation