Installation

1. Version de ruby

Au moment de la rédaction de cet ouvrage, il était recommandé d’utiliser Rails avec Ruby 1.8.6.

2. RubyGems

L’installation est très simple à l’aide de RubyGems, cette application est un gestionnaire de packages Ruby, vous pourrez l’installer à partir de ce lien si vous ne l’avez pas (il est déjà présent avec la version de Ruby pour Windows) : http://rubyforge.org/frs/?group_id=126

L’installation de Rails se fait à l’aide de cette commande : gem install rails, il est recommandé de répondre Y à tous les packages supplémentaires.

Voici la trace obtenue lors de l’installation :

gem install rails
Need to update 40 gems from http://gems.rubyforge.org
........................................
complete
Install required dependency activesupport? [Yn]  Y
Install required dependency activerecord? [Yn]  Y
Install required dependency actionpack? [Yn]  Y
Install required dependency actionmailer? [Yn]  Y
Install required dependency activeresource? [Yn]  Y
Successfully installed rails-2.1.0
Successfully installed activesupport-2.1.0
Successfully installed activerecord-2.1.0
Successfully installed actionpack-2.1.0
Successfully installed actionmailer-2.1.0
Successfully installed activeresource-2.1.0
Installing ri documentation for activesupport-2.1.0...
Installing ri documentation for activerecord-2.1.0...
Installing ri documentation for actionpack-2.1.0...
Installing ri documentation...
Pour consulter la suite, découvrez le livre suivant :
couv_Ruby.PNG
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Introduction
Suivant
Base de données