Prérequis

Pour installer CakePHP en version 3.x, il faut :

  • un serveur HTTP,

  • PHP dans une version supérieure ou égale à la 5.4.16,

  • l’extension PHP mbstring activée,

  • l’extension PHP intl activée.

Bien souvent, les applications utilisent une base de données. CakePHP supporte les bases de données suivantes :

  • MySQL (5.1.10 ou supérieur),

  • PostgreSQL (8 ou supérieur),

  • Microsoft SQL Server (2008 ou supérieur),

  • SQLite 3.

Pour accéder aux données, CakePHP utilise les drivers PDO. Assurez-vous d’avoir l’extension appropriée en fonction du type de base de données choisi.

1. Environnement de développement local

Si vous souhaitez installer CakePHP uniquement sur votre machine, il suffit d’installer un environnement de développement PHP. Plusieurs outils proposent d’installer en une fois, le serveur Apache, le moteur de la base de données MySQL/MariaDB et le serveur PHP.

Voici deux exemples d’environnements de développement PHP à installer :

XAMPP

Lien vers le site : https://www.apachefriends.org/fr/index.html

XAMPP regroupe Apache, MariaDB, PHP et Perl au sein d’une même installation. Il est disponible pour les systèmes d’exploitation Windows, GNU/Linux et Mac.

images/3-1.png

Capture d’écran du site : https://www.apachefriends.org/fr/index.html

WampServer

Lien vers le site : http://www.wampserver.com/

WampServer est un outil similaire à XAMPP, uniquement...

Pour consulter la suite, découvrez le livre suivant :
couv_EP3CAK.png
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Introduction
Suivant
Installer CakePHP grâce à Composer