Créer une formule conditionnelle imbriquée

Lorsqu’un résultat de condition de test implique plus de deux possibilités, vous pouvez imbriquer des formules conditionnelles.

images/fonctionSi.png

Dans ce cas, la formule s’écrit : =SI(test_logique 1;valeur si VRAI;SI(test_logique 2;valeur si VRAI;valeur si FAUX)). La formule conditionnelle n°2 est bien "imbriquée" dans la première.

Vous pouvez ainsi imbriquer plusieurs conditions les unes dans les autres.

Dans cet exemple deux conditions ont été imbriquées dans une troisième : si le Stock final (H4) est inférieur à 100, alors le texte "Commande urgente" est affiché ; si le Stock final est compris entre 100 et 500, le texte "Passer commande" est affiché ; s’il est compris entre 500 et 1000, le texte "Stock compris entre 500 et 1000" est affiché ; si aucune de ces conditions n’est vérifiée, le texte "Stock > à 1000" est affiché.

images/10RBXL16-15.png

Notez qu’en fin de formule, il y a une parenthèse pour fermer chaque condition.

Pour faciliter l’écriture de la formule, vous pouvez scinder les arguments en insérant des sauts de ligne à l’aide des touches AltEntrée.

images/10RBXL16-16.png

L’insertion de sauts de ligne dans une formule n’a aucune incidence sur le résultat.

Pour imbriquer plusieurs conditions, vous pouvez également utiliser la nouvelle fonction d’Excel...

Pour consulter la suite, découvrez le livre suivant :
couv_RB19EXC.png
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Créer une formule conditionnelle simple
Suivant
Combiner l'opérateur OU ou ET dans une formule conditionnelle