Corrigé 6 OSPF totally stubby area

Après avoir mis en place la topologie physique et configuré l’adressage IP, entrez les commandes suivantes sur le routeur R0 :


R0#configure terminal 
R0(config)#router ospf 65000 
R0(config-router)#network 10.0.0.0 0.0.0.3 area 0 
R0(config-router)#network 192.168.0.0 0.0.0.255 area 1 
R0(config-router)#area 1 stub no-summary 
R0(config-router)#exit 
R0(config)#
 

Note

La commande area 1 stub no-summary permet de déclarer l’aire 1 en « totally stub », ainsi toute route apprise à l’aide d’un autre processus de routage (O E2) ou toute route provenant d’une autre aire (O IA) sera remplacée dans l’aire par une route par défaut 0.0.0.0 (O*IA). La commande doit être saisie sur le routeur backbone.

Saisissez les instructions suivantes sur le routeur R1 :


R1#configure terminal 
R1(config)#router ospf 65000 
R1(config-router)#network 10.0.0.0 0.0.0.3 area 0 
R1(config-router)#network 192.168.2.0 area 2 
R1(config-router)#redistribute rip subnets 
R1(config-router)#exit 
R1(config)#interface loopback 0 
R1(config-if)#ip address 172.16.0.1 255.255.255.0 
R1(config-if)#exit 
R1(config)#router rip 
R1(config-router)#version 2 
R1(config-router)#no auto-summary 
R1(config-router)#network 172.172.0.0 
R1(config-router)#exit 
R1(config)#
 

Note

La commande redistribute permet d’injecter les routes d’un processus de routage...

Pour consulter la suite, découvrez le livre suivant :
couv_TP5CIS.png
60-signet.svg
En version papier
20-ecran_lettre.svg
En version numérique
41-logo_abonnement.svg
En illimité avec l'abonnement ENI
130-boutique.svg
Sur la boutique officielle ENI
Précédent
Corrigé 5 OSPF stub area
Suivant
Corrigé 7 Optimisation OSPF